Symptoms

In Microsoft Outlook 2019, Outlook for Office 365, Outlook 2016, and Outlook 2013, when you send an email message from another program such as Microsoft Excel, you receive the following warning message:

 A program is trying to send an e-mail message on your behalf. If this is unexpected, click Deny and verify your antivirus software is up-to-date.

Cause

This warning message is displayed when a program tries to access your Outlook client to send an email message on your behalf, and your antivirus software is detected to be inactive or out-of-date.

Resolution Method 1 - Enable or update your antivirus application

To learn how Outlook detects your antivirus status, follow these steps:

  1. In Outlook, select File, and then select Options.

  2. Select Trust Center, and then select Trust Center Settings.

  3. Select Programmatic Access.

  4. View the Antivirus status that's listed in this window. If the status is anything other than Valid, follow the appropriate steps to enable your antivirus program, or update your antivirus program as necessary.

    Antivirus status

Resolution Method 2 - Change the Programmatic Access Security setting in Outlook

  1. In Outlook, select File, and then select Options.

  2. Select Trust Center, and then select Trust Center Settings.

  3. Select Programmatic Access.

  4. Select the option that you prefer. If you want to stop these warning messages permanently, select the Never warn me about suspicious activity (not recommended) option.

    Never warn me about suspicious activity (not recommended)